My truck

Let's hear all the gory details about your car and how it became alternative fuelled.
Post Reply
alain
Posts: 16
Joined: Sat Jun 23, 2007 1:57 pm
Location: Netherlands

My truck

Post by alain » Tue Mar 03, 2009 2:15 pm

Hi,

Been on here for a while, but never posted anything. I own a '77 Dodge W200 (among other cars) with a turbocharged 318ci on LPG.

Truck

Engine bay

Sorry for the url's, I got an error saying the photo's were too big.
Later,
~Alain~
------------------------------------------------
'69 Dodge Dart - twin GT32's, EFI, 318ci
'77 Dodge W200 - Holset HX50, 318ci
'67 Camaro - no motor yet
'69 Camaro RS - 327ci


User avatar
DODGEN1
Posts: 53
Joined: Fri Nov 07, 2008 12:30 am
Location: NORTH CA

Re: My truck

Post by DODGEN1 » Mon Mar 09, 2009 11:04 pm

are you running 2 converters?

alain
Posts: 16
Joined: Sat Jun 23, 2007 1:57 pm
Location: Netherlands

Re: My truck

Post by alain » Sat Mar 28, 2009 3:31 pm

Yes I am. I started out with one converter, but when I got to about 3psi it would die as if you flicked a switch. Get off the throttle and it would pick right back up. I thought the gas flow through the converter might not be enough, so I tee'd in another converter I had lying around. This solved the problem and the truck runs well all the way to 8 psi. Both the converters are boost-referenced from the carb hat.
Later,
~Alain~
------------------------------------------------
'69 Dodge Dart - twin GT32's, EFI, 318ci
'77 Dodge W200 - Holset HX50, 318ci
'67 Camaro - no motor yet
'69 Camaro RS - 327ci

Post Reply